libdigidocpp 4.6.0
Standards and references

This page collects the specifications, standards, and additional resources referenced by the Programmer's Guide and API documentation.

BDOC2.1:2013

BDOC – Format for Digital Signatures. Version 2.1:2013

https://www.skidsolutions.eu/repository/bdoc-spec21.pdf
Other releases:
https://www.skidsolutions.eu/repository/bdoc-spec20.pdf
https://www.skidsolutions.eu/repository/bdoc-spec212.pdf
https://www.id.ee/wp-content/uploads/2020/08/bdoc-spec21-est.pdf
https://www.id.ee/wp-content/uploads/2020/01/bdoc-spec212-est.pdf

DigiDoc format

DigiDoc file format

https://www.id.ee/wp-content/uploads/2020/08/digidoc_format_1.3.pdf

XML-DSIG

IETF RFC 3275: "XML-Signature Syntax and Processing"

https://www.rfc-editor.org/rfc/rfc3275.html

XML-DSIG 1.1

XML Signature Syntax and Processing. Version 1.1

https://www.w3.org/TR/xmldsig-core1/

XAdES

ETSI EN 319 132-1 V1.3.1 (2024-07) - Building blocks and XAdES baseline signatures
ETSI TS 101 903 V1.4.2 (2010-12) – XML Advanced Electronic Signatures
ETSI TS 103 171 V2.1.1 (2012-03) - XAdES Baseline Profile

https://www.etsi.org/deliver/etsi_en/319100_319199/31913201/01.03.01_60/en_31913201v010301p.pdf
https://www.etsi.org/deliver/etsi_ts/101900_101999/101903/01.04.02_60/ts_101903v010402p.pdf
https://www.etsi.org/deliver/etsi_ts/103100_103199/103171/02.01.01_60/ts_103171v020101p.pdf

XAdES Validation

ETSI TS 102 853 V1.1.2 (2012-10) – Signature validation procedures and policies

https://www.etsi.org/deliver/etsi_ts/102800_102899/102853/01.01.02_60/ts_102853v010102p.pdf

CAdES EN

ETSI EN 319 122-1 V1.2.1 (2021-10) - Building blocks and CAdES baseline signatures

https://www.etsi.org/deliver/etsi_en/319100_319199/31912201/01.02.01_60/en_31912201v010201p.pdf

PKWARE ZIP

ZIP File Format Specification

https://www.pkware.com/documents/casestudies/APPNOTE.TXT

OpenDocument

OASIS "Open Document Format for Office Applications. Version 1.2 Part 3: Packages"

https://docs.oasis-open.org/office/v1.2/cs01/OpenDocument-v1.2-cs01-part3.html#__RefHeading__752803_826425813
Other versions:
https://docs.oasis-open.org/office/v1.0/OpenDocument-v1.0-os.pdf

ASiC

ETSI EN 319 162-1 V1.1.1 (2016-04) - Associated Signature Containers
ETSI TS 102 918 V1.3.1 (2013-06) - Associated Signature Containers
ETSI TS 103 174 V2.1.1 (2012-03) - ASiC Baseline Profile

https://www.etsi.org/deliver/etsi_en/319100_319199/31916201/01.01.01_60/en_31916201v010101p.pdf
https://www.etsi.org/deliver/etsi_ts/102900_102999/102918/01.03.01_60/ts_102918v010301p.pdf
https://www.etsi.org/deliver/etsi_ts/103100_103199/103174/02.02.01_60/ts_103174v020201p.pdf

PDF (PAdES)

ETSI EN 319 142-1 V1.1.1 (2016-04) - PAdES digital signatures

https://www.etsi.org/deliver/etsi_en/319100_319199/31914201/01.01.01_60/en_31914201v010101p.pdf

RFC 2045

Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies

https://www.rfc-editor.org/rfc/rfc2045.html

RFC 2253

Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names. Obsoleted by RFC 4514.

https://www.rfc-editor.org/rfc/rfc2253.html

RFC 4514

Lightweight Directory Access Protocol: String Representation of Distinguished Names

https://www.rfc-editor.org/rfc/rfc4514.html

RFC 3161

Internet X.509 Public Key Infrastructure Time-Stamp Protocol (TSP)

The TSTInfo genTime field records the UTC time at which the time-stamp token was created by the Time-Stamping Authority (TSA).

https://www.rfc-editor.org/rfc/rfc3161.html

RFC 3739

Internet X.509 Public Key Infrastructure: Qualified Certificates Profile

https://www.rfc-editor.org/rfc/rfc3739.html

RFC 3986

Uniform Resource Identifier (URI): Generic Syntax

https://www.rfc-editor.org/rfc/rfc3986.html

RFC 4051

Additional XML Security Uniform Resource Identifiers. Obsoleted by RFC 6931.

https://www.rfc-editor.org/rfc/rfc4051.html

RFC 6931

Additional XML Security Uniform Resource Identifiers. Obsoletes RFC 4051 and is obsoleted by RFC 9231.

https://www.rfc-editor.org/rfc/rfc6931.html

RFC 9231

Additional XML Security Uniform Resource Identifiers

https://www.rfc-editor.org/rfc/rfc9231.html

RFC 4519

Lightweight Directory Access Protocol: Schema for User Applications

https://www.rfc-editor.org/rfc/rfc4519.html

RFC 5035

Enhanced Security Services (ESS) Update: Adding CertID Algorithm Agility

https://www.rfc-editor.org/rfc/rfc5035.html

RFC 5280

Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile

https://www.rfc-editor.org/rfc/rfc5280.html

RFC 6960

X.509 Internet Public Key Infrastructure Online Certificate Status Protocol (OCSP)

https://www.rfc-editor.org/rfc/rfc6960.html

RFC 8954

Online Certificate Status Protocol (OCSP) Nonce Extension

https://www.rfc-editor.org/rfc/rfc8954.html

Trusted Lists

ETSI TS 119 612 V2.4.1 (2025-08) – Electronic Signatures and Trust Infrastructures (ESI); Trusted Lists
ETSI TS 119 612 V2.2.1 (2016-04) – Electronic Signatures and Infrastructures (ESI); Trusted Lists

https://www.etsi.org/deliver/etsi_ts/119600_119699/119612/02.04.01_60/ts_119612v020401p.pdf
https://www.etsi.org/deliver/etsi_ts/119600_119699/119612/02.02.01_60/ts_119612v020201p.pdf

SiVa

Digital signature validation web service that provides SOAP and JSON API to validate files

https://open-eid.github.io/SiVa/

Release notesLibdigidocpp library’s release notes
ETSI EN 319 412-2 V2.4.1

ETSI EN 319 412-2 V2.4.1 – Certificate Profiles; Part 2: Certificate profile for certificates issued to natural persons
ETSI TS 102 280 V1.1.1 – X.509 V3 Certificate Profile for Certificates Issued to Natural Persons

https://www.etsi.org/deliver/etsi_en/319400_319499/31941202/02.04.01_60/en_31941202v020401p.pdf
https://www.etsi.org/deliver/etsi_ts/102200_102299/102280/01.01.01_60/ts_102280v010101p.pdf

QC Certificate Profiles

ETSI EN 319 412-1 V1.7.1 – Certificate Profiles; Part 1: Overview and common data structures
ETSI EN 319 412-5 V2.6.1 – Certificate Profiles; Part 5: QCStatements

https://www.etsi.org/deliver/etsi_en/319400_319499/31941201/01.07.01_60/en_31941201v010701p.pdf
https://www.etsi.org/deliver/etsi_en/319400_319499/31941205/02.06.01_60/en_31941205v020601p.pdf

QC Certificate Policy

ETSI EN 319 411-2 V2.6.1 – Policy requirements for Trust Service Providers issuing EU qualified certificates
ETSI TS 101 456 V1.4.3 (2007-05) – Policy requirements for certification authorities issuing qualified certificates

https://www.etsi.org/deliver/etsi_en/319400_319499/31941102/02.06.01_60/en_31941102v020601p.pdf
https://www.etsi.org/deliver/etsi_ts/101400_101499/101456/01.04.03_60/ts_101456v010403p.pdf

DigiDoc librarieshttps://www.id.ee/en/rubriik/digidoc-libraries/
ID-software GitHub projecthttps://github.com/open-eid
Libdigidocpp GitHub projecthttps://github.com/open-eid/libdigidocpp